Cannot run Unity application in 3D


I’m trying to run a Unity application in Windows 7, but I get a window that just says:

Failed to initialize player

Details: InitializeEngineGraphics failed

The application is simply a build of StylusObjectManipulationSample. Everything works fine in the Unity player, but I can’t run it as a standalone application (which seems necessary to get the third dimension).

I changed the building settings as follows:

    Target: windows, Architecture: x86.

In Player Settings:

    Other settings: Put OpenGLES2 at the top of the list for Graphics API for Windows (unchecked Auto-graphics api for windows)

    XR Settings: Checked Virtual Reality Supported

I then made a shortcut to the build and added these flags to Target in Properties: -force-opengl -enable-stereoscopic3d. If I don’t run with the shortcut, I just get a pink screen.

Background info: Windows 7, Unity 2017.3.1f1, AMD Radeon R7 200 series (with freshly updated drivers). zSpace Experience runs fine. zSpace Configuration Check looks fine except for a Warning on the GPU.

Help would be very much appreciate. Chances are I missed a crucial setting somewhere, but after a couple hours I haven’t figured it out. Also, seems to be offline.


Your mention of “-force-opengl” & “-enable-stereoscopic3d” suggests to me that you’re using the 4.0 version of our plugin which doesn’t support the 2017.x.x versions of Unity. If that’s the case, we suggest following the links below for the newer 5.0 plugin and it’s release docs. Be sure to give the docs a read as the player settings, exe args, etc. are different.

Although the new 5.0 recommends using DirectX11, because you’re on win7, you’ll need to follow the notes regarding opengl. (for example, OpenGLCore will be needed rather than OpenGLES2)