Flashing screen when in fullscreen


I recently start to develop an app on my zSpace AIO with Unity3D 2019.4.9f1. My problem is taht when i build my app and start it in fullscreen, there is a “black” flashing screen. The only way I find to solve this issue is to run my app in windowed mode but I want to run it in fullscreen. Is there any solutions to this ? I already searched on this forum but find nothing to help me. Thanks !

Florent Duval.

Hi Florent,

I haven’t heard of this particular problem before, but considering how you describe it, I would guess your graphics driver might be problematic. The first thing to try is updating your System Software and GPU through the zSpace App Manager.

If you can confirm that these are up-to-date, but the problem still persists, then my next suspicion would be the project itself. If you can share a project or at least of build of it, I’ll make time to give it a try and at least see if I can reproduce the problem.

Hi again,

I tried to update as many things as I can but i can’t see the “zSpace AIO GPU Update” in my app manager, even with updating it. The bug is still here. Should I try to update the GPU driver manually?

That’s odd. Please PM me a screen capture of the results from zSpace Configuration Check so that I can inspect the details of your machine in detail.

I tried to PM you but permission was denied so… here the configuration screenshot.

Are you not able to update the system software through app manger? Please double check this. If you can, please update it and look for the GPU update again afterwards.

That’s all I can do for the system software. Isn’t it the latest version of it?

Yes, but your config check is seeing something different. Your zSpace Configuration Check appears to be out of date. It appears to be version 3.1.xxxx, there should be an available 4.0.xxxx update in App Manager. If you can update config check, then do so, have it run again and send me another capture of the results the newer version reports.

Hi !

So I tried to update my configuration check but it’s kind of impossible. The app manager doesn’t want to update more than and there is no direct link on zspace.com/downloads. Where can I find a link to update it manually?

I have conferred with an associate who raised a question. Are you running Windows 8? If so, then that is most likely the root cause for the system’s lack of ability to update. You will need to be running at least Windows 10, version 1903 or higher.

Not windows 8 but 8.1. I currently have no way to run this device on windows 10. The device is a loan and is not the property of my company. Is there any solutions for manual updating?

I’m asking around to see if there’s a graphics driver version we can recommend to you. That’s about as much as I’ll be able to do for you unless you can manage to upgrade the system to windows 10.

Here is a driver that should work with Windows 8.1. Please let me know if it resolves your issue.


Well, I installed the new driver but unfortunalety it doesn’t fix the issue. I checked the current version with dxdiag to see if the update has been made and it does.