Issues with setup, Failed to initialize zSpace Core SDK


I’m have issue getting zspace set up and working in unity, i’m using unity personal licence version 2019.1.6

ive downloaded the z space zCore Unity Plugin 5.0 and imported the package into unity.

as directed i Draged the zCore prefab into the Hierarchy window, when i look at the Zcor script component of the prefab in the hierarchy window i see the fallowing error “Failed to properly initialize zSpace Core SDK”.

i also have these error in me debug terminal

Failed to initialize zSpace Core SDK: (RuntimeNotFound)
zSpace.Core.GlobalState:.ctor() (at Assets/zSpace/Core/Scripts/ZCore.singleton.cs:196)
zSpace.Core.GlobalState:get_Instance() (at Assets/zSpace/Core/Scripts/ZCore.singleton.cs:30)
zSpace.Core.ZCore:OnEnable() (at Assets/zSpace/Core/Scripts/ZCore.cs:679)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)


Failed to initialize global state. Disabling zCore GameObject.
zSpace.Core.ZCore:OnEnable() (at Assets/zSpace/Core/Scripts/ZCore.cs:682)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

any help would be greatly appreciated

Hi Michael,

It appears that the plugin cannot find the zSpace System Software. This is software that comes pre-installed on zSpace hardware and runs in the background persistently. My guess is that you’re trying to use the zCore plugin on a non-zSpace system. zCore doesn’t officially support this quite yet.

If my assumption is correct that you are running the plugin on a non-zSpace system, there are two solutions.

The first solution is to develop with the Unity Editor directly on zSpace hardware.

The second solution is to install zSpace System Software on your non-zSpace system. This is not officially supported, but it has been known to suffice for build server machines. Developing with this method is technically possible but will be highly limited without a zSpace system for at least prototype iteration and testing.

Taking a step back, if you are actually experiencing these errors on a zSpace system, then I recommend attempting to reinstall System Software either through the pre-installed zSpace App Manager, or acquiring it from our downloads page.

Follow the link below to find our System Software downloads. If you’re attempting to use zCore on a non-zSpace system, then choose the 200 model software to install. If you need it for a zSpace system, then choose the download that corresponds to your model.

Alex S.

Hi Alex,

thanks for the prompt response. Yes i was trying to use the plug in on a computer other then the zpace system. So now i installed unity on the zspace and imported the zcore package, i fallowed all the instructions for changing the player settings and enabling vr everything appeared to be working, but now unity seems to be broken all i see is a black screen and the error message, i cant even open the scene or game view windows. Even when i created a new unity project without zspace plugin included its still the same error

here’s a picture

Hi Michael,

What you have run into is very obscure and I don’t have any experience in encountering it. The first thing I would try is locate the “Layout” drop-down in the top right, then select the “Restore Factory Settings…” option. If that doesn’t work, my next step would be to reinstall the editor. At this point, if the issue continues to return, I recommend installing an older version of Unity3D (2018 or 2017) since zCore has not been tested in 2019.

Alex S.

Yes Restore Factory fixed it! now i just have to not cause it to happen again, i think it may have had to do with 2 zcore prefabs being in the scene at the same time. initially i attached one to the scene and when i ran it, it created a second one and then i ran again and that’s when this error happened.

Thanks for letting us know that fixed your issue! I’ll keep an eye out for this happening to others.