Stereoscopy doesn't work on zSpace AIO and 300


I have an issue with my builds from Unity. When the app is running, it seems like the stereoscopy isn’t working. There is no “3D” effect and the right eye of the glasses is showing a gray veil. I already searched on the support but didn’t find the same issue. I’m on zSpace AIO and zSpace 300.

All my parameters are correctly set as on the guide.

Thanks for the help.

Hi Florent,

Are you using zCore 5 or 6?

What is your camera’s near-clip plane value?

Are you building the app with opengl or d3d11 support? If you’re building with support for both, do they both fail in the same manner you describe?

Does the stereo XROverlay encounter the same problem when enabled for the editor’s game view? Or does the issue only occur in builds?

I’m using zCore 6.

My near clip value is 0.03.

I tried to build with both d3d11 and opengl and they both have the issue.

Unfortunately, I don’t know what is the stereo XR Overlay and I don’t use it. Is it some part of the zSpace package ?

The XR Overlay is an augmentation of the Unity editor’s game view window that allows it to preview in stereo.

Which version of unity3d are you using?

If you create a fresh project and generate a standalone build of one of the samples included with zCore6, does the same issue occur?

So, I tried with the XR overlay (thanks for the tip) and I don’t have any issues when running in playmode with it.

I’m on the 2019.4.9f1 version of Unity.

I also tried a new project and run a build with a sample scene, same here. I have the issue with a build but not with the playmode + XR overlay…

Hi Florent,

I’m still uncertain whether this could be a Unity Project setup issue or a system issue. Could you share with me a build of one of the zCore6 sample scenes? Whether the build presents the same issue running on my system should settle that.

Sharing the results of zSpace Configuration Check would be helpful to determine the general state of your machine. (choose to export as file. dont upload to zspace)

Are you running Windows 8 or Windows 10?

Have you run through updating zSpace System software and AMD graphics drivers through App Manager lately?

Hi Alex,

Here a build with a sample scene:

And the configuration check for the AIO:

I’m running windows 10 on both the AIO and the 300.

Both devices are updated with the app manager.

Hi Florent,

After looking at your project I see that you are using URP. Unfortunately anything derived from Scriptable Render Pipeline essentially breaks Unity’s VR support for Stereo Display (non head-mounted).

The most practical solution will be to remove URP and rely on Unity’s built-in Standard Render Pipeline.

If for some reason you absolutely need to use URP, then I can offer some more detail in terms of where the conflict most likely lies, but Unity nor we officially support URP with non-HMD stereo it at this time.

Alex S.