Stylus problems

Hi!
I hope someone can help with this problem. I have been having serious lag issues with the stylus. It seems to happen when I have been working for several hours on a project. When the problem starts, the lag is unbearable. It starts freezing and makes working on the simulation impossible. I tried swapping the stylus out, but after a couple of weeks, the same thing happened with the new stylus. It seems to be overheating…it gets a little warm. Has anyone else experienced this? What should I do?

Hi rjdean,

Overheating is certainly concerning but not something I’ve heard of before. The stylus is essentially just two IR LED lights, a gyroscope sensor, and a tiny motor for haptic feedback.

Which zSpace hardware model are you experiencing this with?

I don’t want to dismiss the rare possibility of hardware failure out-of-hand, but we should eliminate other possible culprits first.

Is it more accurate to describe the issue as a persistent delay between physical motion and corresponding motion in-app, or does a periodic absence of tracking entirely more accurately describe the behavior?

You mentioned this occurs after several hours. zSpace tracking is particularly sensitive to natural sunlight. Is there a chance, during the time that the issues occur, that sunlight is casting into the environment that the zSpace occupies, either in the direction of the zSpace, or the opposing walls behind the user?

Does head tracking suffer any ill effects around the same time that the stylus does?

Usually stylus lag can be attributed to a slow frame-rate of the running application. Have you taken any steps to eliminate the app being developed as a possible contributor to the issues experienced?

If you’re developing with an AIO/300 model, you should have a “zSpace Control Panel” where you can run diagnostic tests. If possible, let us know whether you experience the same symptoms when running its “Stylus Tracking Test”.

I’ll ask around and see if anyone has ever heard of an overheating stylus, but in the meantime, any additional information would be greatly appreciated.

Alex S.

Just following up. If you’re on a 200 model, it’s been recommended that you check which ethernet port that the stylus is plugged into. The port nearest to the power connection is the correct port for the stylus. If yours is plugged into the ethernet port closer to the USB ports, this might be the cause, and you should plug it into the correct port.

Alex, Thanks for your responding.

We are working on a 200 model using the Unity plugin. We have run the Stylus tracking test and it works fine. We are working in a room without much sunlight so I don’t think that is an issue. To more accurately describe the behavior, there is a periodic absence of tracking entirely. But the head tracking continues to work, no problems there. You mention that the problem may be attributed to a slow frame-rate, but wouldn’t that result in a delay between physical motion and the corresponding motion in-app? What would cause the periodic absence of tracking?

Thanks for your assistance!

FYI, I just opened a new project in Unity without any assets, and we still have the periodic loss of tracking for the stylus…

Have you verified that the stylus is plugged into the correct port per my second reply?

yes…it is plugged into the proper port

Just to confirm so far.

  • The stylus is plugged in adjacent to the power port.
  • Natural light has been eliminated as a possible culprit.
  • ZSpace Control Panel diagnostic tests don’t exhibit the same periodic tracking loss.

As you’ve described things, the fault would seem to lie with the Unity plugin. Given that Unity is our most used engine, and yet we’re not familiar with it causing such issues, my current inclination is to seek further confirmation that the fault doesn’t lie elsewhere.

See the link here for a bare-bones sample built from our Native SDK.
BasicStereoGLSample.zip

I would be most appreciative if you would verify that this sample also does not exhibit the behavior.

Alex S.

I just tried the diagnostic tools again and there was a loss of tracking this time. I will verify the sample and get back to you right away. Thank you.

Just to update you, I opened the sample you sent. It also exhibits the same behavior – the periodic loss of tracking.

Robert

Thanks for the information so far and for continuing to bear with me here. Would you please verify which stylus pictured below resembles the one plugged into your model 200 zSpace? Left or right?

The one on the left.

Alex,

Thanks for your help so far. Any thoughts yet as to what may be causing this periodic loss of tracking?

Hi rjdean,

The only thing left worth checking would be the power adapter in use. If it doesn’t read 12V & 6.67A for the output, that might be a possible culprit.

After conferring internally, the diagnosis is that it’s most likely a hardware fault. Your model 200, as old as it is, is unlikely to still be under warranty. On that off chance that it is actually still warrantied, contacting support@zspace.com would be the next course of action. Otherwise, there unfortunately isn’t much more assistance that I can offer.

Alex S.

Hi Alex,

Thanks for all your help so far. Regarding the power adapter, it is actually 19.5V - 4.62A output. Do you think this could be the culprit? Odd though, since we’ve been using it for several years with this adapter. For this most recent project, we’ve connected a second monitor to the computer to make the coding a bit more convenient. This wouldn’t have any effect, would it? Also, this is the first time we’ve used the Unity plugin for a project. Previously all of our projects were completed using EON Reality.

I will look into acquiring a new zSpace, but I’m up against a deadline and wanted to make sure I’ve explored all possibilities before going that route.

Thanks again for your help.

Robert

Hi rjdean,

I’m not aware of secondary monitors causing such issues. This is a common configuration.

Most likely you have the correct adapter, but for the sake of due-diligence, I’m sending you a PM so we can follow up in more detail.

Alex S.

Thanks for sharing the good information
vmware