Unity apps we create are not in stereo now

When we got our zSpace many years ago, we could develop apps using Unity and they worked fine. But maybe 3 years ago, our apps were not in stereo any more. The demos that came with the zSpace still work fine.

We have a couple of very experienced Unity and graphics developers who tried a lot of things in the settings to make them work, but no luck.

What are we doing wrong?

Thanks in advance!

Hey Herb,

I’ll need some more information.

  • zSpace model
  • windows version
  • zSpace System Software version
  • graphics driver version
  • unity3d editor version
  • zCore plugin version
  • unity builds
    • d3d or opengl
    • 32 or 64 bit

If you’re using a zSpace model 300, have you tried toggling Window’s 3d display mode setting in the display settings? d3d builds like it off and opengl builds like it on, or vice versa. That has been a more recent gotcha.

Alex S

Hi Alex,

zSpace model: AIO-24-GL
windows: Windows 10 Pro Educational
zSpace software: See attached image
graphics driver: see attached image
[12:12 PM] Catalano, Paul A {He, Him} (GRC-LSX0)[BQMI]

Unity Version: 2018.2.14

zCore Plugin: Can’t determine the zCore version because for some reason the project files are missing the plugins


Unity Build: Direct3D11, 64-bit

Hey Herb,

That is unfortunately much older than even our more recently end-of-life zSpace models. You are going to be largely on your own here, but I’ll try to toss some ideas out here.

Since you’re saying your own app isn’t working, but the demo apps still are, and assuming you’re launching the demo apps from desktop shortcuts, open the demo’s shortcut properties up and check the launch args. Back in those days, we had to use a number of launch args for unity apps to get them initializing correctly. You could try and see if using the same launch args for your own app gets it firing again.

The zCore packages come with test scenes. Have you tried building these scenes to see if you get different results? Try building them in a new/clean project as well.

I’m really shooting in the dark here. The more information you can get me, the more help I might be able to offer. Anything like error logs, detailed explanations of the behavior you’re seeing, or rundowns of what you’ve tried so far will go a long way.

Alex S

Alex, thanks for your willingness to help even though our system is so old!

We will try some more things today but this bit of data might help.

We found the Unity projects that the developer (an intern) used to make the apps for us. So we opened them up in Unity. When we use the included preview window at runtime in the editor, it works perfectly!

BTW, you can’t tell from my email, but this is for NASA, where I work. NASA appreciates the help!

Hey Herb,

Very cool! We’d love to see what NASA is getting up to with our hardware.

Something else that came to mind. The in-editor preview leverages D3D. Since that’s working for you but builds aren’t, maybe the builds are trying to run opengl. You could try forcing D3D for builds in Unity’s project settings or, through the command line arg -force-d3d11 (assuming the project settings graphics api option is set to auto)

Alex S


Thanks for that advice but it didn’t help.

Actually it made it worse. Lots of flickering.

We can use it from within the unity dev app for now.