zView didn't show as 3D

The problem is when i connect the camera and configured it then i open the demo and start using the pen nothing happens in the zView it shows as 2D not 3D and i tried to do as in the zView videos like when i click on the pen and pull the object it didn’t show as in the video.

Hi Abdullah,

This photo shows your application running directly on the zSpace. zView is a separate application that runs in parallel with your application and presents a special view to a separate extended display. For me to diagnose issues with zView, you will need to take a picture of what is being presented by zView on the extended display.

Alex S.

I already connected another screen with zView but when I open the build the zView screen shows as 2d object not as a zSpace user can see (3d).
Maybe I misunderstood the main purpose of zView and maybe not. So, can you explain please?

please check the image

Hi Abdullah,

Thank you for confirming that the hardware is set up correctly.

We first need to determine whether the fault lies with your software or elsewhere. Have you confirmed that any other pre-existing apps present the AR view correctly? I recommend starting/installing zSpace Demo, which is available in App Manager for this purpose.

Next, there is a sample scene that comes included with the zView Unity Package. If you build that single scene as a standalone app, does that work as expected?

Which version of the zView package are you using?

Which version of zCore is being used?

Which version of Unity3D?

Which render pipeline is being used in the project?

Alex S.

I already tried the zView on zSpace Demo also it’s not worked.

Unity version 2019.4.30f1
zView version 6.0.0
zCore version 6.0.2
Render Pipeline >> built-in render pipeline

If it doesn’t work with zSpace Demo, then the fault probably lies with the system or zView configurations. I would recommend continuing to troubleshoot with zSpace Demo to minimize additional variables.

Have you performed calibration in zView yet? The wrench/spanner symbol in the toolbar will run you through it. At the second step, do all six patterns become highlighted in green?

I did all of that correctly and I’m sure of that. I applied exactly what mentioned in the documentation.

Upon closer inspection of your photograph, it appears that zView was not connected to your app at the time. Unless your app is connected, the AR mode will only show the webcam output. Can you confirm that the issue persists when zView is connected? You will know that the app is connected when the green checkmark turns to a red X. Again, please test this with zSpace Demo to minimize variables.